Bandizip for Windows XP



Windows XP users must install Bandizip 5.x because Bandizip 6.0 does not support XP anymore.


Download Bandizip v5.20 »